Updating to Eyelink 1000 plus

meyert11's Avatar

meyert11

18 Mar, 2021 07:05 PM

Hi Chris,

I moved a computer that was using an Eyelink 1000 to a new setup using Eyelink 1000 plus. I ran one of our experiments on it, and it will connect, but 2 wierd and possibly related things happen. When mworks finishes calibrating, and I rerun calibration, the eye signal is no longer present. Additionally, when I stop the experiment and close it, it takes a longer than normal time for the Eyelink connection to close (usually this is super fast, but we're talking a good 30 seconds to a full minute). I'm using mworks 0.9.

I tried to go into the I/O section of the experiment to see if there was a different setting for eyelink 1000 vs 1000 plus, but I didn't see anything. My thoughts are: 1- there seems to be a hickup between mworks and eyelink in shutting off the network; 2 - I'm not sure if anyone in the lab previously has fully configured the Eyelink for Mworks, are there special settings I need to put on the Eyelink computer for it to seamlessly communicate with mworks? I didn't see anything in the Support site about configurations other than networking settings, which are present.

Thoughts?

  1. Support Staff 1 Posted by Christopher Sta... on 18 Mar, 2021 09:09 PM

    Christopher Stawarz's Avatar

    Hi Travis,

    That is strange. I know other labs use the 1000 Plus with MWorks, and I haven't received any reports of similar problems.

    I don't believe there's any particular configuration you need to do on the EyeLink PC. There are no MWorks-side settings that would need to change when switching from 1000 to 1000 Plus.

    It sounds like the network connection between the EyeLink PC and the MWorks Mac is flaky. Can you tell me how they're connected? Is it just a single Ethernet cable going from the Mac to the PC? If so, maybe try a different cable. If there's a network switch, a USB Ethernet adaptor, or any other components in between, maybe try removing or replacing them.

    If you haven't already, you could also try rebooting both the EyeLink PC and the MWorks Mac. It's possible that some networking driver on one or the other system has gotten in to a bad state. Rebooting should resolve that.

    If none of this helps, then try updating to the latest version of the EyeLink API. (If you haven't already, you'll need to create an account on the SR Research support site to access that page.) The package you want is "EyeLink Developers Kit v1.11.1" in the macOS section. Run the installer, then restart MWServer. I doubt this is the source of the problem, but you never know.

    If the issue persists, please let me know, and we'll try to come up with some other possible solutions.

    Cheers,
    Chris

  2. 2 Posted by meyert11 on 26 Mar, 2021 06:02 PM

    meyert11's Avatar

    Hi Chris

    < Update> it turned out to be the EyeLink developer kit version. I updated
    from 1.10 to 1.11 and it worked!

    Thanks Chris!!

    Travis

  3. Support Staff 3 Posted by Christopher Sta... on 26 Mar, 2021 08:41 PM

    Christopher Stawarz's Avatar

    Great! Thanks for letting me know.

    Chris

  4. Christopher Stawarz closed this discussion on 29 Mar, 2021 01:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac