Issues with 2013 Mac Pro?

Christopher Stawarz's Avatar

Christopher Stawarz

10 Mar, 2021 04:33 PM

Hi Sachi,

Alina shared part of an email you sent her with me, which I hope you don't mind me quoting here:

The problem I had (which Michael might be alluding to) was with my current rig: the Mac Pro machine is old (~2013), and when I updated the OS to the latest version, MWorks threw a lot of “skipped display refresh” errors because the graphics card couldn’t support it for some reason. Thus, I had to downgrade back to MacOS 10.12 (which Mac no longer officially supports). (Similar situation as this other user).

Is the Mac Pro in question of the "black trashcan" variety? If so, then it would be great if you could share more about the problems you were having, as that model (late 2013) shouldn't have issues running the latest macOS and MWorks versions. (Also, I happen to have one here at home, so hopefully I could reproduce and resolve whatever problems you've seen.)

The discussion you referenced was about the 2010/2012 Mac Pro. That's a very different model, and I don't think any were ever used in DiCarlo Lab setups.

Thanks,
Chris

  1. 1 Posted by Sachi Sanghavi on 10 Mar, 2021 05:45 PM

    Sachi Sanghavi's Avatar

    Hi Chris,

    Yes, the Mac Pro in question is the trash can. I was running MacOS 10.14 with MWorks 0.8, and I encountered a lot of “Warning: Skipped X display refresh cycles” when running a standard RSVP experiment. There’d be four or five trials (the number varied) where I wouldn’t have any warnings, but then I’d get multiple warnings back-to-back. This happened with movies and images. Ko’s rig has the same Mac Pro but running MacOS 10.11, and the identical code runs on it without any warnings (I haven’t checked to see if he has updated his hardware though). I then tried upgrading my MWorks from 0.8 to 0.9, but that didn’t resolve the issue. That’s when I found the issue I referenced about the 2010/2012 Mac Pro on the forums, and thought I’d try downgrading to MacOS 10.12. This has resolved the issue, mostly.—I still get the "Warning: Skipped X display refresh cycles”, but it’s generally a single warning in a couple of trials, and X=1 always. (I wanted to try downgrading to MacOS 10.11, but I thought it wouldn’t be worth the effort).

    Hope this helps! Let me know if there’s anything else I could share. Sorry, I should have updated you, but since I got it to work satisfactorily, I didn’t ping you.

    Sachi

  2. Support Staff 2 Posted by Christopher Sta... on 11 Mar, 2021 07:45 PM

    Christopher Stawarz's Avatar

    Hi Sachi,

    Thanks for sharing these details. The problem you're describing sounds very much like a known issue with most of the point releases of macOS 10.14. Do you happen to know the specific version of 10.14 you were running? If it was 10.14.5 or earlier, then this is almost certainly the issue you were seeing. The problem was fixed in 10.14.6 (the last 10.14 point release), so I wouldn't expect you to see it there.

    If you were running macOS 10.14.6, then I'm not sure what the source of the problem is. MWorks 0.8 was released before macOS 10.14 and was never fully tested on that OS version. However, you said you saw the same issue with MWorks 0.9, which was thoroughly tested on macOS 10.14, so this probably isn't relevant.

    I imagine you don't want to mess with your system now that it's up and running. But if you ever feel so inclined, I'd recommend upgrading to macOS 10.14.6 or later and MWorks 0.9 or 0.10. Your 2013 Mac Pro shouldn't have any issues with that combo. If it does, please let me know!

    Thanks,
    Chris

  3. Christopher Stawarz closed this discussion on 29 Mar, 2021 01:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

17 May, 2022 02:12 PM
16 May, 2022 03:12 PM
04 May, 2022 06:02 PM
03 May, 2022 01:30 PM
02 May, 2022 10:47 PM