Matlab issue

Lindsey Glickfeld's Avatar

Lindsey Glickfeld

09 Nov, 2020 02:25 PM

Hi Chris,
We recently had to update a couple of computers to Catalina (Duke sprung a bunch of security requirements on us earlier this week).
The computers are both running Mworks 0.9.dev (2019.04.24) and were cloned from a computer with Mojave (the OS didn't stick, so we had to upgrade to Catalina).
Everything seems to be okay so far, except for the Matlab interface.
When we tried collecting data, we got an error that the Matlab engine was found dead (see screenshot). We thought that it was maybe because of the very old version of Matlab that was on the computer, so we downloaded Matlab 2020b (turns out that 2019a was already installed too). I used the terminal to change the Matlab version, but now when we run it there is no output at all and Matlab doesn't start. After a while it says that it is processing 1 event, but there have been many trials that have passed. Also, Matlab appears not to actually open (the instance appears in the bar at the bottom, but there's no dot under it suggesting that the app has started). I tried Matlab 2019a also, but same result.
On the second computer (actually the first one I was trying to get working), I had forgotten to use the terminal to assign the Matlab version, and thought that maybe deleting the old version of Matlab would help. Not sure if it's causal, but now there is no "Matlab Interface" option to select in the dropdown (see second screenshot). I then tried to assign the Matlab version via terminal, but still don't get the option for the Matlab Interface.
Please let me know if you have thoughts about how to fix these issues, or if you have questions.
Thanks,
Lindsey.

  1. Support Staff 1 Posted by Christopher Sta... on 09 Nov, 2020 02:48 PM

    Christopher Stawarz's Avatar

    Hi Lindsey,

    Can you launch and run the MATLAB application(s) directly (not via MWorks) on the updated machines? It's possible that you need to re-activate MATLAB on those systems, and trying to launch the app is the quickest way to find out.

    If the MATLAB application works as expected, then something must be amiss with the connection to MWorks. MWorks 0.9.dev (2019.04.24) should work with MATLAB R2016b or later, so R2019a and R2020b should both be fine. Once you've created the appropriate symlink to the MATLAB version you want to use, all that's left to do is restart MWClient, and things should work.

    If you've created the symlink and restarted MWClient, and things still don't work, then I'm not sure where the problem lies. Maybe try restarting the Mac, in case there are lingering MATLAB processes running that are somehow messing things up?

    Cheers,
    Chris

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • MatlabInterface.jpeg 428 KB
  • IMG-0772.jpeg 363 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac