mwk and mwk2

mc7055's Avatar

mc7055

02 Oct, 2019 10:05 PM

Hi Chris,

I'm using the function 'getEvents.m' on a machine that has an earlier version of MWorks and the data comes from version 9. My code is crashing. Do the versions of MWorks in the data acquisition machine and processing machine have to match?

Thanks!
mariana

  1. Support Staff 1 Posted by Christopher Sta... on 03 Oct, 2019 01:46 PM

    Christopher Stawarz's Avatar

    Hi Mariana,

    Do the versions of MWorks in the data acquisition machine and processing machine have to match?

    Normally, no. However, MWorks 0.9 introduced a new data file format, which the Python and MATLAB tools from earlier MWorks versions can't read. So in this case, yes, you need MWorks 0.9 to read data files created by MWorks 0.9.

    Cheers,
    Chris

  2. 2 Posted by mc7055 on 03 Oct, 2019 01:58 PM

    mc7055's Avatar

    Hi Chris,

    Thank you for the answer. And will the new installation be backwards
    compatible? Meaning can I use the new version to process data from the
    older data format?

    Thank you,
    mariana

  3. Support Staff 3 Posted by Christopher Sta... on 03 Oct, 2019 01:59 PM

    Christopher Stawarz's Avatar

    Meaning can I use the new version to process data from the older data format?

    Yes, absolutely. The MWorks 0.9 data tools read both the old (.mwk) and new (.mwk2) file formats.

    Chris

  4. 4 Posted by mc7055 on 03 Oct, 2019 02:03 PM

    mc7055's Avatar

    Wonderful! Thank you.

  5. Christopher Stawarz closed this discussion on 04 Oct, 2019 07:45 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac