MWServer hang

mhisted's Avatar


21 Jun, 2019 02:07 PM

Hi Chris,

I'm seeing MWServer hang when I try to load any experiment, even a simple one.

....but then I upgraded to today's nightly, and now it doesnt' hang anymore. Maybe the report below is still useful.


OS: 10.14.4
MWorks: Version (2019.03.19)
(This worked before upgrading to Mojave, and I tried reinstalling that nightly; still the same hang)

Screenshot shows the point it crashes.
Nothing in the MWServer debug log (i.e. I set MWORKS_WRITE_MESSAGES_TO_STDERR=1).

I also ran dtruss on MWServer. I started it after connecting, then loaded the experiment. Output is attache in the log file.

  1. Support Staff 1 Posted by Christopher Sta... on 21 Jun, 2019 02:13 PM

    Christopher Stawarz's Avatar

    Hi Mark,

    Yes, some change in 10.14.4 caused a deadlock in MWorks. The fix isn't in the 2019.03.19 nightly, but 2019.03.28 and after should have it. It's also in the 0.9 release.


  2. Christopher Stawarz closed this discussion on 26 Jun, 2019 01:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac