stimulus still visible when same colour as background

beshoy.agayby's Avatar

beshoy.agayby

13 Mar, 2019 10:28 PM

Hi Chris,

I was testing a task where target (a disk) needs to be detected at random locations on the screen. When varying the colour values of the disk, i noticed that when the disk has the same colour values as the background, the borders of the disk are visible as a thin white line. It doesn't appear on the mirror window but only on the 2nd display. I tried a rectangle which was better (reduced borders), but still the same issue. Any idea what caused this?

Cheers,
Beshoy

  1. 1 Posted by beshoy.agayby on 14 Mar, 2019 12:25 PM

    beshoy.agayby's Avatar

    Hi Chris,
    Just an update, this issue only occurs with the ellipse stimulus not with the rectangle one.

    Cheers,
    Beshoy

  2. Support Staff 2 Posted by Christopher Sta... on 14 Mar, 2019 02:08 PM

    Christopher Stawarz's Avatar

    Hi Beshoy,

    I haven't been able to reproduce this issue yet. What color are the stimulus and background when you see the white line?

    Thanks,
    Chris

  3. 3 Posted by beshoy.agayby on 20 Mar, 2019 11:29 AM

    beshoy.agayby's Avatar

    Hi Chris,

    Sorry for the late reply. I tried reverting back to the 0.8 version as i was using a nightly version (not the latest one). I noticed that this issue isn't there anymore. And speaking of the nightly version, I tried to use the latest one and the stimulus didn't even come up. I will test it on another computer to be sure, but any idea why is this?

    Cheers,
    Beshoy

  4. Support Staff 4 Posted by Christopher Sta... on 20 Mar, 2019 01:09 PM

    Christopher Stawarz's Avatar

    Could you please send me an example experiment that demonstrates the issues you're seeing?

    Thanks,
    Chris

  5. 5 Posted by beshoy.agayby on 26 Mar, 2019 09:57 PM

    beshoy.agayby's Avatar

    Hi Chris,

    Sorry for the delay. I attached a file with an example protocol.

    Cheers,
    Beshoy

  6. Support Staff 6 Posted by Christopher Sta... on 27 Mar, 2019 04:59 PM

    Christopher Stawarz's Avatar

    Hi Beshoy,

    Thanks for sending the example.

    Unfortunately, I'm not able to reproduce either problem using the latest nightly build. When the stimulus color is identical to the background color, the stimulus is invisible. When the colors are different, the stimulus always appears. I tested on four different Macs and an iPad, with the same results each time.

    I've attached a minimal version of your experiment that just displays the target disc while looping over all values of target_contrast, displaying each for one second. On all my test machines, the disc is invisible when its color matches that of the background. If you run this on your machine, do you see the white border when the disc should be hidden?

    Also, it'd be helpful to know more details about the system on which you're seeing these issues. Can you run the following command in Terminal and send me the output?

    system_profiler SPSoftwareDataType SPHardwareDataType SPDisplaysDataType
    

    Thanks,
    Chris

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac