setup variables

Rishi Rajalingham's Avatar

Rishi Rajalingham

03 Mar, 2016 02:21 PM

Hi Chris
Small question: I noticed that my current mworks install does not have a setup_variables.xml file in its appropriate directory, but seems to work fine (however, there is a backup install that does have this file). How is this possible (and how would one edit the setup values in this case)?
Thanks

  1. Support Staff 1 Posted by Christopher Sta... on 03 Mar, 2016 02:40 PM

    Christopher Stawarz's Avatar

    Hi Rishi,

    The setup_variables.xml file can be in two places:

    • For all users: /Library/Application Support/MWorks/Configuration
    • For a specific user: $HOME/Library/Application Support/MWorks/Configuration, where $HOME is the path to the user's home directory

    If MWorks is working normally, then you must have one of these on your machine. (The MWorks installer checks both locations, and if neither contains a setup_variables.xml file, it installs a default one for all users.)

    The easiest way to edit configuration variables is via MWServer's Preferences window. Any changes you make there will be saved to the user-specific config file (which will be created if it doesn't already exist).

    For more info, see Configuring MWorks.

    Cheers,
    Chris

  2. Christopher Stawarz closed this discussion on 07 Mar, 2016 06:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac