Error at the end of the task

Setayesh Radkani's Avatar

Setayesh Radkani

23 Jan, 2021 10:56 PM

Hi Chris,

I'm running a custom-made eye calibration task (the task is coded with OOG library). I have tried the task on other computers (including iMac) and it's working. However when I run it on my iMac, after the final trial of the task, I get the following error, which prevents the task from terminating.

00:00:28: ERROR: Cannot receive on ZeroMQ socket: Context was terminated
00:00:28: ERROR: Terminating incoming connection
00:00:28: ERROR: Cannot send on ZeroMQ socket: Context was terminated
00:00:28: ERROR: Terminating outgoing connection

I attached the file for the calibration task. I'm using my mouse to set the eye_x and eye_y of the eye_tracker.

Thanks,
Setayesh

  1. 1 Posted by Setayesh Radkan... on 23 Jan, 2021 10:58 PM

    Setayesh Radkani's Avatar

    Sorry, I guess the file was not attached.

  2. Support Staff 2 Posted by Christopher Sta... on 26 Jan, 2021 02:19 PM

    Christopher Stawarz's Avatar

    Hi Setayesh,

    That's very strange. The ZeroMQ context used by MWorks is created once and persists until MWServer is closed. Nothing that MWorks does should cause it to be terminated.

    It's possible that this issue results from an unintended interaction between different versions of the ZeroMQ library. On your iMac, have you installed any Python packages that embed ZeroMQ (pyzmq being the most likely suspect)? If so, maybe try uninstalling said packages and testing if that resolves the issue.

    Chris

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac