NIDAQ

hansem's Avatar

hansem

12 Sep, 2019 05:24 PM

We're having a problem with USB-based NIDAQ (6212). We need to reboot the computer every time we start a new session (so that its analog output channel for reward works). It didn't happen before we upgraded MWorks to 0.9. It seems that some buffer in 6212 needs to be cleaned up. Any idea on this?

  1. Support Staff 1 Posted by Christopher Sta... on 12 Sep, 2019 05:47 PM

    Christopher Stawarz's Avatar

    Hi Hansem,

    On the computer that needs rebooting:

    1. What version of macOS are you running?
    2. What version of NI-DAQmx Base is installed?

    Also, what happens when you don't reboot before starting a new session? Does MWorks report any errors?

    Thanks,
    Chris Stawarz

  2. 2 Posted by hansem on 12 Sep, 2019 08:41 PM

    hansem's Avatar

    Thanks for prompt response, Chris!

     We're using 10.12 (Sierra) on Macbook pro and NI-DAQmx base 3.7 was
    installed.
     When we didn't restart Mac and start a new session, I didn't see any
    reported error (Mahdi - cc'ed - may have something to add).

     Best,
     Hansem

  3. 3 Posted by Mahdi Ramadan on 13 Sep, 2019 03:18 AM

    Mahdi Ramadan's Avatar

    Hi all,

    I also do not see an error either.

    Mahdi

  4. Support Staff 4 Posted by Christopher Sta... on 13 Sep, 2019 01:35 PM

    Christopher Stawarz's Avatar

    NI-DAQmx base 3.7 was installed

    This is almost certainly the problem. MWorks 0.9 isn't compatible with NI-DAQmx Base 3.7. (In fact, I don't understand how it works at all, even after rebooting.) You should upgrade to the latest driver version (15.0).

    Cheers,
    Chris

  5. 5 Posted by Mahdi Ramadan on 15 Sep, 2019 05:52 PM

    Mahdi Ramadan's Avatar

    Hi Chris,

    I tried installing the latest driver (15.0), but for some reason the MWOKS
    stopped being able to connect to the eye tracker (I tried restarting,
    disconnecting and connected cable,etc.). So I tried re-installing 3.7
    because it was at least partially working, but now I get this error below.
    Now I don't have a working version which puts me in a bad spot because my
    research is very time sensitive at this stage. Can we please find time to
    figure this out tomorrow? I would really appreciate it.

    Mahdi

  6. Support Staff 6 Posted by Christopher Sta... on 24 Oct, 2019 02:07 PM

    Christopher Stawarz's Avatar

    Just to close this out: The problem was that the Mac in question had a mixture of NI-DAQmx Base 3.7 and 15.0 installed. Uninstalling all of NI-DAQmx Base and then reinstalling 15.0 resolved the issue.

  7. Christopher Stawarz closed this discussion on 24 Oct, 2019 02:07 PM.

  8. hansem re-opened this discussion on 24 Oct, 2019 02:25 PM

  9. 7 Posted by hansem on 24 Oct, 2019 02:25 PM

    hansem's Avatar

    Sure, thanks for your help!

  10. Christopher Stawarz closed this discussion on 24 Oct, 2019 02:32 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac