Frame skips on Mac Pro in 10.12

T. Vincenza Parks's Avatar

T. Vincenza Parks

16 Apr, 2019 06:37 PM

Hi Chris,

This is from quite a while ago, but I haven’t noticed much a problem since then. However, today one of the computers (identical to one Evan was using, but a different one) is having this issue after rebooting it. Is there something I can do to provide you with more information?

Thanks,
Vinci

> Evan Remington wrote:
>
> Hi Chris,
>
> Do you mind taking a look at our Mac Pro? Going to 10.12 (from 10.8 and 10.13) initially seemed to solve the problem (for a while!) but now it's skipping frames again. It's even happening after a reboot.
>
> Thanks,
> Evan

  1. Support Staff 1 Posted by Christopher Sta... on 16 Apr, 2019 06:41 PM

    Christopher Stawarz's Avatar

    Hi Vinci,

    On the Mac Pro that's having problems, can you run the following command in Terminal and send me the output?

    system_profiler SPSoftwareDataType SPHardwareDataType SPDisplaysDataType
    

    Also, what version of MWorks are you using?

    Thanks,
    Chris

  2. Support Staff 2 Posted by Christopher Sta... on 16 Apr, 2019 07:57 PM

    Christopher Stawarz's Avatar

    Hi Vinci,

    Thanks for that info.

    I see your Mac Pro has two graphics cards, each of which has a single display attached. Can you try attaching both displays to the same graphics card? That may improve graphics performance, especially if you're using MWServer's mirror window.

    If you want, I can stop by sometime tomorrow and have a look at the setup with you.

    Cheers,
    Chris

  3. Support Staff 3 Posted by Christopher Sta... on 17 Apr, 2019 03:02 PM

    Christopher Stawarz's Avatar

    Hi Vinci & Alex,

    While checking out one of the Mac Pro's that was having this issue, I noticed that the system process icdd was consuming a fairly large amount of CPU time. I tried to unload, kill, or otherwise disable the process, but it kept running (or restarting). However, an online discussion noted that turning off the Wi-Fi had resolved a similar problem. I tried this, and the result was that icdd immediately settled down to using a negligible amount of CPU, and MWorks ceased to emit skipped refresh warnings.

    I also tried the other steps described in the discussion (resetting SMC and NVRAM). However, these did not resolve the issue, which continues to occur when Wi-Fi is enabled.

    Since this Mac has a wired network connection, is there any need to have Wi-Fi enabled on it? If not, then disabling Wi-Fi seems to be an easy solution. If you do need Wi-Fi enabled, then you could take more drastic measures to disable icdd. This will probably break something, though it may not be anything that matters for your purposes.

    As for why having Wi-Fi enabled causes icdd to go wonky and thereby mess with MWorks' display updates... I guess Apple might know? I certainly do not!

    Cheers,
    Chris

  4. 4 Posted by T. Vincenza Par... on 17 Apr, 2019 03:37 PM

    T. Vincenza Parks's Avatar

    Hi Chris,

    Thanks for coming by to help us this morning! I don’t believe there is a reason to keep Wi-Fi enabled, but I’ll check with other lab members. Hopefully keeping Wi-Fi disabled will prevent this from happening again!

    Thanks,
    Vinci

  5. Christopher Stawarz closed this discussion on 20 Apr, 2019 04:44 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac